Ads by RevenueHits

Linuxeros Faq

Ads by Bidvertiser

Busqueda sobre Linux y software libre

Problema de arranque de Debian cuando tiene windows al lado

Pregunta

Hola . . . gente . . . ojala alguien se digne en leer mi post, pero no
 encuentro un forma mas simple de explicar mi problema.

 Mi problema es bastante complicado y desde mi punto de vista hasta casi
 imposible, a ver os explico . . .

 Preciso instalar debian etch en una pc, que tiene una tarjeta madre intel
 D945GC (nada rara bastante común diría yo), un procesador Pentium D 2,8 Ghz,
 y un disco duro MAXTOR de 80 G, de los antiguos con IDE, y son bastante
 voluminosos, en este disco decidí dedicarle 20G a Debian, aun que no lo crean
 mi problema comienza en el hecho de que Debian debe coexistir con windows XP,
 una situación muy común y que ya había resolvido antes (desde mis inicios con
 fedora), añadir que anteriormente había instalado kubuntu en la misma pc, y
 ando perfectamente, pero despues lo quite y la pc estaba entera con windows
 xp + vista (por si acaso la pc no es mía si no de mi hermano), un vista que
 no gusto asi que se lo quito, para instalar Debian hice lo que siempreh hice y
 siempre me funcionó, les paso a detallar.

 1.- Un backup de los discos ;-)
 2.- Inicio un instalador de acuerdo a lo que necesito, en mi caso install
 tasks=”kde-desktop, standard”
 3.- Ya en el particionado, particiono como siempre lo hice y siempre funcionó,
 una partición swap lógica, una / también como lógica, Aceptar , Aceptar hasta
 llegar a grub.
 4.- Nada raro que el grub reconociera a win como Vista/Longhorn (loader), y
 termino la instalación al parecer con éxito.
 5.- Al reiniciar . . . sorpresa . . . no carga grub, es mas me indica que
 revise el cable de alimentación . . .

 Despues en el paso 3 del particionado añado una partición /boot como lógica,
 da el mismo resultado, viendo que si pongo / como primaria si carga el grub
 pero no inicia linux en modo gráfico (nunca supe por qué, pero asi siempre me
 sucedio), decido añadir /boot, como primaria y con marca de arranque, . .
 al fin inicia el grub, y mi debian también lo configuro . . . y demas, cuando
 ya estaba saltando de felicidad, inicio windows . . . me pasa algo raro,
 reconoce hardware nuevo . . y a un disco duro, no doy mucha importancia,
 ahora decido iniciar debian, parece empesar a cargar de forma correcta, pero
entra en bloqueo justo cuando en la pantalla me indica:

 Loading essential drivers ok
 Running/scripts/init-premount ok

 Y nunca mas funciona, ya probe de todo incluso con 2 unidades de discos duros
 físicamente diferentes, el caso es que cuando inicia windows de todas formas
 me estropea a mi debian, algo rarísimo dado que tengo mi pc con win + debian
 hecho de la forma que les explique arriba y nunca trajo problemas, segun pude
 ver (y no soy ningun experto), al parecer por una extraña razón win busca las
 particiones primarias marcadas como de arranque y primero les quita la marca,
 segundo le hace algo a su tabla de particiones, asi las estropea, y sospecho
 que el windows loader de vista tiene tomado pro asalto el MBR del disco, eso
 impide que se inicie algun sistema sin primaria, formatearia todo el disk, mi
 hermano tiene toda si tesis en el, y el backup es una imagen.


Respuesta

A mi me paso algo parecido, instale Debian Etch, configura el GRUB, todo
Ok hasta ahi; solo que cuando reinicie me decia que no existia un
dispositivo de donde podia arrancar.
Mas bien tenia una copia de "Super Grub Disk"(SGD), una herramienta que me
salvó varias veces. Al utilizar el SGD podia entrar a cualquier
distribucion, en mi caso tengo una de WINdows Xp , Ubuntu Feisty y la de
Debian Etch que estaba probando, entonces supuse que el problema no era los
discos, solo un problema en el MBR.
Reinicie la maquina otra vez con el SGD y en las opciones que tiene para
Windows elegi "Activar Particion", y creo que eso era lo que faltaba, porque
entro a WINdow tranquilamente,
luego otra vez con el SGD, en la parte de Linux volvi a instalar el grub
de Etch. Y ya no tuve ningun problema.

Ojala te sirva.

Ads By Bidvertiser

Tienda linuxeros FAQ

29440009-121797753

Ads by Daily Motion