Ads by RevenueHits

Linuxeros Faq

Ads by Bidvertiser

Busqueda sobre Linux y software libre

Instalacion CentoOS en Servidor HP

Pregunta

Tengo problemas al instalar centos en un equipo servidor de las sgtes características :

HP Proliant DL320e Gen8(v1)
2 discos duros cada uno de 1TB
(Funcionara como mirror, RAID1)

Los problemas:
 Al instalar Centos 6.1 luego de arrancar, en la parte sale un error "de competencias" y no reconoce la tarjeta de red.

Posteriormente hice el intento con la version 6.3 , después de finalizar la instalación me arroja el sgte error:
    Attempty boot form DVD (C:)
   Attempty boot from USB
   Attempty boot from  Hard Disck (C:)
(Se me bloquea el teclado, y me suena un pitido "beep" del equipo cada vez que presiono el teclado)

Respuesta
No puedo darme cuenta de lo que puede ocurrir en el primer caso, pero
cuando instalaste 6.3 el error parece un problema de booteo, ¿los
discos duros como están organizados?, ¿cual tiene el boot, donde
instalaste grub? la configuración del BIOS ¿cual disco tiene como
principal?, ¿como realizaste la configuración del RAID?
Otra respuesta
 Que tipo de Raid estas implementando. Se recomienda por hardware. Revisa tu Bios y tu compatibilidad de Raid que has realizado

Y otra respuesta
Yo instale varios server proliant Gen8 con ubuntu y casi seguro que es por el RAID. 

1.- Descargate la utilidad de HP, creal el usb para actualizar la bios.

2.- Para que no tengas problemas asegurate utilizar un kernel mayor o igual a 3. Con las versiones 2.6 no funciona la red.

Solo decirte que por temas de empresa al final tuve que instalar un windows 2012 server.

Comentario sobre la pregunta
El asistente de Centos(particiones) te muestra los 2 discos, RAID1 no deberia mostrarte solo 1, (o es una cuestion visual solamente)

Y mas otra respuesta
Si RAID por hardware sólo se presenta un disco al sistema operativo. Este disco es llamado disco virtual. Este disco virtual es independiente del tipo de RAID elegido, en tu caso que tienes 2 discos, lo lógico es que uses RAID1 (mirror) Es decir, hasta aquí tienes todo en orden.

Si la tarjeta de red no es reconocida, entonces en la sección de configurar red no tendrás la opción "Networking", como no tienes tarjetas no hay nada que configurar. Así que este es otro problema.
Una vez terminado de instalar tu sistema debiera de arrancar desde el disco, asegúrate que todos tus parámetros de configuración del BIOS hacen eso. ¿ Está tu servidor conectado a un SAN ?..Si fuera así lo más rápido y tonto es desconectar el equipo del SAN para estar 100% seguro de que la instalación se hará únicamente en el disco local.

Mas y más respuestas

¿ has visto que ocurre al instalar Grub ?
¿ has visto que errores te reporta el proceso de instalación ?
Todo esto puedes mirar cuando estás en plena instalación y saliendo a la línea de órdenes con Ctrl+Alt+F2, y tienes el resto de consolas Alt-F3, Alt-F4 y Alt-F5 para ver mensajes de error y otros.
Por lo que indicas el problema parece ser al momento de instalar Grub en el cargador de arranque. Cuando termine de instalar, antes de reiniciar el equipo ve a esas consolas y fíjate que pasó. En particular en la consola Alt-F5 vas a ver mensajes extras de la operación, el la consola Alt-F3/Alt-F4 deberías ser capaz de mirar la orden grub que ejecuta el instalador. Finalmente otra cosa que puedes intentar es ejecutar tu mismo la orden grub para instalar el código de arranque, desde la consola Alt-F2
Te diría que uses CentOS 6.5, si es por un tema de compatibilidad con hardware. Y si usaras RHEL 6.5 tendrías un teléfono para llamar a soporte.

Comentario sobre la pregunta inicial

Voy a intentar inicialmente con centos 6.5.

Por cierto, en medio de la instalacion me pide colocar contraseña para GRUB pero yo lo omito.
Por otro lado es posible que el tamaño para el /boot (1024MB) sea muy poco?
Es posible?
Les pregunto a uds que tienen mas experiencia.
El equipo tiene 2 discos(cada 1 TB), RAID-1.

Ya hice las actualizaciones de controladores (de HP) para esta version de Centos 6.3.

Respuesta

Puede funcionar si es un problema de compatibilidad con hardware. 

El problema que reportas, a mi me indica que no tiene nada que ver con eso. Se ve que tu servidor no encuentra el dispositivo de arranque, si ya haz confirmado que todo a nivel de BIOS está bien, entonces lo único que puede ser es que no encuentra nada en el sector 0 y eso podría ser por que Grub falla al instalar. Por eso te decía mirar en las consolas de instalación.

ener 1GB en /boot es un desperdicio, con 200MB es suficiente.

Comentario sobre esta última respuesta

Ya instale centos 6.5, verifique en la interfaz de HP(Intelligent Provisionning) y esta la configuracion del RAID1 me muestra, 1 unidad logica de 1TB y 2 unidades fisicas de 1TB.

Sin embargo en la parte de particionamiento.
me aparece 2 unidades :
    sda   libre  983545
    sdb   libre  983545
por otro lado el GRUb esta instalado en el /dev/sda
Ahora me aparece unas lineas y me esta pidiendo algo en linea de comandos GRUB, de esta manera
grub>
(que debo hacer)

Respuesta

El driver del raid no esta funcionando, por eso ve dos discos, cuando
instalas solo lo instala en el sda por eso el boot no funciona.
Buscaste si tu modelo especifico de servidor tiene drivers para el
raid en radhat?

Otra respuesta

Me entro la curiosidad y dice que necesitas drivers para el Raid de tu
servidor, aca te da los pasos

http://adf.ly/1fFn8e

Debes cargar el driver antes de instalar.

Comentario a esta respuesta

Cabalmente, ya vi esta pagina y segui el procedimiento(los pasos).
Probe recien con la version 6.5 y no reconoce el RAID1.
(por que los drivers del USB son de otra version 6.3)

volvi a instalar con la version 6.3, y los drivers mencionados en el USB, termino de hacerme la instalacion y me salio la pantalla y por defecto el usuario Guest.
Luego reinicie para ingresar nuevamente con el cable de red y demas, pero nuevamente
(antes retire el USB y el cd centos), no me levanta y me da el error de siempre.
"emptty boot from cd ", "empptyt boot from USB "C:"
no se que hacer..

Exactamente estas son las lineas de error:

"Attempting Boot From CD-ROM"
"Attempting Boot From USB DriveKey (C:)"
"Attempting Boot From Hard Drive (C:)"

Respuesta

Los Gen8 tiene una opción para montar un "virtual install disk" en opciones avanzadas de la Bios. Se supone que ahi tienes los drivers para los SO soportados por HP. 

De todas formas:
Usas la opción "Intelligent Provisioning" ? F10 al arranque. Es un asistente que te ayuda a instalar el OS y configura el hardware con los parámetros necesarios(si el os esta soportado por HP).

Otra respuesta

Si entiendo bien, con CentOS 6.3 te funcionaron los controladores de RAID del fabricante y reconoce exitosamente el Disco Virtual (el creado por RAID1). Entonces hasta aquí vamos bien, parece que el problema es el paso siguiente, que se relaciona con la instalación de Grub y/o la carga de los controladores del RAID luego de reiniciar el equipo. Lo que yo haría, una vez terminada la instalación. Es asegurarme de construir un nuevo initrd (initial RAM Disk) que contenga los controladores RAID que necesito (los del proveedor). Seguidamente me aseguraría que Grub se instaló correctamente en MBR del disco virtual.

Este enlace te va dar ideas, pero tienes que tener en cuenta que estás en "modo instalación" y todos los sistemas de archivos del sistema final están en una ubicación temporal. Un simple mount te dará una figura del asunto.

http://adf.ly/1fFnBV

Ads By Bidvertiser

Tienda linuxeros FAQ

29440009-121797753

Ads by Daily Motion