Ads by RevenueHits

Linuxeros Faq

Ads by Bidvertiser

Busqueda sobre Linux y software libre

PgAdmin 3 1.10.5 no funciona

Pregunta

Estoy teniendo un error que me muestra el siguiente mensaje Cuando intento

crear una nueva BD desde pgAdmin3:
-------------------------------------------------
Ha ocurrido un error:

ERROR:  no existe la columna «datconfig»
LÍNEA 1: ...b.dattablespace AS spcoid, spcname, datallowconn, datconfig,...
---------------------------------------------------


-tengo instalado los siguientes:
---------------------------------------------------------------------
ii  gambas2-gb-db-postgresql       2.21.0-2         The PostgreSQL driver
for the Gambas database component
ii  postgresql-9.1                 9.1.1-1~bpo60+1  object-relational SQL
database, version 9.1 server
ii  postgresql-client-9.1          9.1.1-1~bpo60+1  front-end programs for
PostgreSQL 9.1
ii  postgresql-client-common       124~bpo60+1      manager for multiple
PostgreSQL client versions
ii  postgresql-common              124~bpo60+1      PostgreSQL
database-cluster manager
ii  postgresql-contrib-9.1         9.1.1-1~bpo60+1  additional facilities
for PostgreSQL
ii  pgadmin3                       1.10.5-1         graphical
administration tool for PostgreSQL
ii  pgadmin3-data                  1.10.5-1         graphical
administration tool for PostgreSQL - documentation
----------------------------------------------------------------------------
Tambien probe por consola hice los siguiente:
------------------------------------------------------------------------------

postgres en squezee:/home/ghaspaer$psql -U postgres -W

postgres=#_

vim /etc/postgresql/9.1/main/postgresql.conf

fsync = on
#listen_addresses='localhost'
listen_addresses='*'

postgres en squezee:/home/ghaspaer$ createdb MyTest
postgres en squezee:/home/ghaspaer$ psql MyTest
psql (9.1.0)
Digite «help» para obtener ayuda.

MyTest=#

MyTest-# CREATE TABLE libros (id_libro int,nombre varchar)
MyTest=# INSERT INTO libros VALUES (1,'gunchelo');
MyTest=# SELECT * FROM libros;
 id_libro |  nombre
----------+----------
        1 | gunchelo
(1 fila)

-----------------------------------------------------------------------------


desde ya muchas gracias por ayuda me pudieran dar ... XD

Respuesta

Un primer problema podría ser la versión de pgadmin3, creo que era
compatible con la versión 8.4.x de postgresql. Y la otra podría ser
que te falta algún paquete de pgadmin3.

Ads By Bidvertiser

Tienda linuxeros FAQ

29440009-121797753

Ads by Daily Motion